Popular: Data updated October 27, 2026

Categories

Internet1,356
Communication321
Audio & video898
Graphics & design539
Office & productivity1,124
Developer tools3,134
AI tools529
Security & privacy385
System tools3,114
Games523
Education & science239
Network & IT284

Servers & self-hosting for Windows (page 2)

Web, media, DNS and game servers you can run on Windows.

This category lists 68 Windows apps: 60% open source, 6% free closed source. The most popular are Caddy, Universal Media Server and Jellyfin Media Player. 11 have a native ARM64 build and 68 a documented silent install. Last update: October 26, 2026.

#App Licence
51 Sante DVD Burning ServerSante DVD Burning Server can receive studies from medical scanners, PACS servers and DICOM viewers and automatically burn and print them in EPSON and PRIMERA CD/DVD producers. 1.2.2 Proprietary August 22, 2025 142.3 MB —
52 Sante Worklist ServerSante Worklist Server (MWL Server) is an autonomous program that can receive via HL7 communication messages the patients demographics and scheduling information of exams that are stored in a HIS/RIS system (Hospital/Radiology Information System) 2.4.3 Proprietary August 22, 2025 7.9 MB —
53 Time-Sync ServerTime-Sync is a freeware software to synchronize the time of your system 1.91.0.0 Proprietary January 13, 2026 — —
54 DiskSavvy ServerDiskSavvy Server provides a full-scale client GUI application and a command line utility, which can be used to control one or more DiskSavvy Servers locally or through the network. 17.3.14 Proprietary October 1, 2025 11.6 MB —
55 SyncBreeze ServerSyncBreeze Server allows one to execute multiple, simultaneous file synchronization operations, monitor disks and directories and trigger file synchronization operations after a user-specified number of changes 17.3.16 Proprietary October 2, 2025 9.9 MB —
56 Mybase ServerMybase is an intuitive knowledge base management software that allows entry of unstructured text, webpages, images, documents, emails and even arbitrary files without regard to length or format. 8.3.0 Proprietary October 24, 2025 — —
57 RackSight DesktopDesktop rack and server visibility with Redfish monitoring. 1.1.9 Open source September 10, 2026 — —
58 RackSight IIS ServerMulti-user RackSight deployment for Windows Server and IIS. 1.1.9 Open source September 10, 2026 — —
59 CharruaPACS Advanced EditionCharruaPACS is a PACS server that excels for its easy installation and maintenance. 6.34 Proprietary October 30, 2025 104.7 MB —
60 Charrua WorkStationCharrua WorkStation is an intuitive and efficient DICOM viewer, designed to operate on Windows systems. 6.33 Proprietary October 25, 2025 36.1 MB —
61 PrintSCPPrintSCP transforms the way medical studies are printed, replacing traditional film with high-quality paper printing from Windows, providing printed copies to patients and referring physicians. 12.0 Proprietary October 25, 2025 5.0 MB —
62 palctlREST-native Palworld dedicated server control for Windows. 1.0.0 Open source July 22, 2026 — —
63 Vovsoft Log AnalyzerLog Analyzer is a tool that helps you search huge text files. You can search log files larger than gigabytes using this utility. 3.0.0.0 Proprietary October 14, 2026 3.6 MB —
64 Vovsoft Syslog ServerBy using Vovsoft Syslog Server, you can view and archive syslog messages in real-time. 2.4.0.0 Proprietary October 20, 2025 2.3 MB —
65 极空间ZSPACE Private Cloud 2.4.2023051208 Free June 19, 2023 275.2 MB —
66 haneWIN DHCP ServerThe software implements a DHCP/BOOTP Server based on RFC 2131. 3.1.28.1 Proprietary December 15, 2025 1.1 MB —
67 haneWIN DNS ServerThe server can run as Primary or Backup name server and supports dynamic DNS updates based on RFC 2136. 2.0.17.0 Proprietary September 12, 2025 903 KB —
68 haneWIN TFTP ServerThe software implements a multithreaded TFTP Server based on RFC 1350 including all extensions specified in RFC 2347-2349 (blocksize, transfer size, timeout options). 1.7.2.1 Proprietary September 12, 2025 699 KB —