Aquesta és una versió anterior. La versió actual és la 5.8.0. DNSControl 5.8.0 · Data de publicació:
Fitxers d’instal·lació 4.27.1
| Arquitectura | Tipus | Àmbit | Mida del fitxer | Baixa | SHA256 |
|---|---|---|---|---|---|
| 64 bits | ZIP → Portable | — | — | github.com | VirusTotal |
| ARM64 | ZIP → Portable | — | — | github.com | VirusTotal |
L’enllaç i l’SHA256 provenen del manifest comunitari del Gestor de paquets del Windows. Convé comparar el hash del fitxer baixat abans d’executar-lo.
Notes de la versió
Greetings DNS fans!
- POWERDNS can now manage "varients". The tag you assign to the domain ("example.com!tagname") is used as the PowerDNS varient. A flag enables this.
- INWX's enforcement of the RFC 7505 prohibition of mixed regular/null MX records is now checked at "push" instead of "preview". In other words, we let the API decide if the records are valid instead of trying to emulate (i.e. guess) INWX's algorithm.
- NETCUP now supports TLSA, POWERDNS supports the "LUA" pseudo record type.
- ROUTE53 now supports RoleArn and ExternalId.
- DKIM_BUILDER() has been refactored to improve input validation and error handling.
- ...and many documentation updates.
FYI: There was no v4.27.0 release.
Thanks to all contributors involved in this release! This is a community project and we couldn't do it without all of your contributions!
Changelog
Provider-specific changes:
- c1b90d06a092f4fb3b28c934243f6297d65c3d9d: INWX: Let the API (not DNSControl) enforce the RFC 7505 prohibition of mixed regular/null MX records (#3805) (@eliheady)
- 6ef064877859f3dbc096112c8896160af9e91e3f: NETCUP: add TLSA support (#3802) (@jpschley)
- 25dd06aaa3e4fb599621c4007b177bca175f9c18: POWERDNS: Map dnscontrol Tags to powerdns Variants (#3803) (@pefeigl)
- 2a4e2509bcba1046bd8dba1bbc5cbace0830573c: POWERDNS: New record type: LUA (#3815) (@eratzlaff)
- 8f13dd10300b858d589625300b06b96a627ccdaa: POWERDNS: Split horizon feature now enabled by flag (#3829) (@eratzlaff)
- a1e74eb11f9bd81e46761a2a6be10d10bb244c32: POWERDNS: Zone creation now abides by variant tags (#3830) (@eratzlaff)
- 24f602a5a17b4b98cd4f3cf79fb4a52d3a6cec13: feat(Route53): Add support for RoleArn and ExternalId #3816 (#3817) (@kevinneufeld)
Documentation:
- f365902508f52db1fcda193104293143d8a3aa05: DOCS: Add internals for ordering (#3811) (@blackshadev)
CI/CD:
- 70c1febe23b624a4ed1f928b780bbc4569753fc1: Build(deps): Bump actions/upload-artifact from 4.6.2 to 5.0.0 (#3806) (@dependabot[bot])
- 2df7a9d6ed453e9f2253bc8cb415ef81cd381dea: Build(deps): Bump alpine from 3.22.1 to 3.22.2 (#3818) (@dependabot[bot])
- b7c4cac75984d02dcc7064690c6d3eae181dd9d3: fix(DKIM_BUILDER): allow empty pubkey (#3800) (@matteotrubini)
- d8aa89028ecf1d346033aade2c97f7277794add3: refactor(DKIM_BUILDER): improve input validation and error handling (#3812) (@matteotrubini)
Dependencies:
- 60e5fa6c4fbdfc6ea4acbd1802fcc089384d6eda: CHORE: Update dependencies (#3825) (@tlimoncelli)
- 71c2cc24cafa034efa3b2bc8c510b6d275f06242: CHORE: Update dependencies (#3831) (@tlimoncelli)
Other changes and improvements:
- bfc2b26911110a38626f3c3b228cab99c022bd70: CHORE: generate-all.sh (#3827) (@tlimoncelli)
- 237de6f2e194331d139f902187b80a95e0463cdf: docs(backups) Emphasize the warning about BIND backups (#3799) (@tlimoncelli)
Deprecation warnings
[!WARNING]
- REV() will switch from RFC2317 to RFC4183 in v5.0. This is a breaking change. Warnings are output if your configuration is affected. No date has been announced for v5.0. See https://docs.dnscontrol.org/language-reference/top-level-functions/revcompat
- NAMEDOTCOM and SOFTLAYER need maintainers! These providers have no maintainer. Maintainers respond to PRs and fix bugs in a timely manner, and try to stay on top of protocol changes.https://github.com/StackExchange/dnscontrol/releases/tag/v4.27.1